0

Eclipse: Failed to load the JNI shared library jvm.dll

Neulich wieder auf einem frisch aufgesetztem Windows-System Probleme mit Eclipse gehabt. Beim Eclipse-Start kam folgende Meldung:

Failed to load the JNI shared library „C:\Program Files (x86)\Java\jre7\bin\client\jvm.dll“

Der Fehler kommt daher, dass Eclipse keine passende JDK-Version gefunden hat.
Nur die folgenden funktionierenden Kombinationen konnte ich feststellen:

  • 32-bit OS + 32-bit Eclipse + 32-bit JDK (nur 32-bit)
  • 64-bit OS + 32-bit Eclipse + 32-bit JDK
  • 64-bit OS + 64-bit Eclipse + 64-bit JDK (nur 64-bit)


Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.